Kirjaudu sisäänKäyttäjätunnusSalasana
Kirjaa minut aina sisään automaattisesti    
Rekisteröidy
Rekisteröidy
Kirjaudu sisään tarkistaaksesi yksityiset viestit
Kirjaudu sisään tarkistaaksesi yksityiset viestit
Arkku.net Foorumin päävalikko » Ohjelmointi

Lähetä uusi viesti   Vastaa viestiin
PHP heittää herjaa XHTML:n kanssa
Näytä edellinen aihe :: Näytä seuraava aihe  
Kirjoittaja Viesti
Kookoz
-


Liittynyt: 26 Elo 2006
Viestejä: 4

LähetäLähetetty: 2.9.2006 19:39    Viestin aihe: PHP heittää herjaa XHTML:n kanssa Vastaa lainaamalla viestiä

Yritän tehdä sivuilleni systeemiä, jossa on valmiina yla.html ja ala.html, jotka includetetaan jokaiseen sivuun. Kun avaan sivun, saan seuraavanlaisen virheilmoituksen:
Kääntäjä kirjoitti:
Parse error: syntax error, unexpected T_STRING in /home/kookoz/domains/palmu.arkku.net/public_html/yla.html on line 1


Ja tämä line 1 (ja koko yla.html) näyttää tältä:
Koodi:

(yla.html)
<?xml version="1.0" encoding="ISO-8859-1"?>
<!DOCTYPE html
PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
"DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="fi">
    <head>
        <title>Palmu</title>
   <link rel="stylesheet" type="text/css" href="tyyli.css" />
    </head>

    <body>
       <div id="navi">
      <img src="img/otsikko.gif" alt="PALMU" class="otsikkokuva" />
      <a href="#" title="Etusivu">Etusivu</a>
      <img src="img/vene.gif" alt="vene" class="vene" />
   </div>
   <div id="sisalto">


Koodi:

(index.php)
<?php include("yla.html"); ?>
<p>Tähän tulee sisältöä.</p>
<?php include("ala.html"); ?>


Koodi:

(ala.html)
   </div>
    </body>
</html>


Mistäköhän vika johtuu? Kun yhdistän sivut yhteen tiedostoon manuaalisesti, validaattori sanoo sen olevan puhdasta XHTML:ää.
Takaisin alkuun
Näytä käyttäjän tiedot Lähetä yksityinen viesti
Poistettu
Vieras





LähetäLähetetty: 2.9.2006 21:59    Viestin aihe: Poistettu Vastaa lainaamalla viestiä

Poistettu
Takaisin alkuun
Kookoz
-


Liittynyt: 26 Elo 2006
Viestejä: 4

LähetäLähetetty: 3.9.2006 10:41    Viestin aihe: Vastaa lainaamalla viestiä

Kiitos, nyt toimii. Oletin jostain syystä, että riviä tarvittiin tiedostossa - sekoitin varmaan XHTML:n XML:ään. Hieno juttu, että foorumilta saa näin nopeasti ja kätevästi apua (yksinkertaisissakin asioissa).
Takaisin alkuun
Näytä käyttäjän tiedot Lähetä yksityinen viesti
Näytä edelliset viestit:   
Lähetä uusi viesti   Vastaa viestiin    Arkku.net Foorumin päävalikko » Ohjelmointi Kaikki ajat ovat GMT + 3 tuntia
Sivu 1 Yht. 1

 
Siirry:  
Et voi kirjoittaa uusia viestejä tässä foorumissa
Et voi vastata viesteihin tässä foorumissa
Et voi muokata viestejäsi tässä foorumissa
Et voi poistaa viestejäsi tässä foorumissa
Et voi äänestää tässä foorumissa